Submit a ticket

Peoplenet - Overview

Updated on Follow
3 out of 3 found this helpful

Peoplenet, a workforce time entry and time management solution, integrates with the Avionté application. 

 

Notes Contact your Avionte Client Manager to begin the integration process. A license will be installed on the Avionté side to enable Peoplenet.
The optimal integration is available in versions 15.1.6 and newer.
Peoplenet terms must be mapped into the Avionté system. Terms like "Regular," "Overtime," and "Doubletime" must be mapped to Avionte's terms like "Reg" instead of "Regular."

 

 

Demo Video

 

 

 

Setup

The Peoplenet integration setup is comprised of four parts - Peoplenet Subscription, Integration Configuration, Import/Export Configuration, and User Authorization

 

 

Peoplenet Subscription

Avionté customers interested in using Peoplenet for time tracking must contact Peoplenet directly to sign up for services and obtain an integration key. http://www.peoplenet.com/contact-us/ 

Contact your Avionté representative with the Peoplenet integration key. This is key is used to license your integration with the Avionté application. 

 

 

Integration Configuration

After obtaining credentials from Peoplenet, the Avionté application must be configured to communicate with the Peoplenet account. 

 

  1. From the Start Page, navigate to Actions > Admin Tools > Peoplenet Time Clocks.

  2. Select the desired Staffing Supplier from the drop-down menu.
    1.png

  3. Enter the integration key provided by Peoplenet.
    • Avionte customers must contact Peoplenet directly to sign up for services and obtain an integration key. The integration key is used to license the integration with the Avionté application.
    • http://www.peoplenet.com/contact-us/ 

  4. Check the checkbox to indicate the subscription is Active.

  5. Click Save Subscription
    • The key is now sent to Peoplenet for verification. A validation status and time stamp will appear in the Integration Key Validation section. 

  6. Click Check Status to update the validation status for the current integration key. The possible returned results are listed below. If a Valid or Invalid response is received, a time stamp will display next to Response Received
    • Note: To enter a new key when a valid integration key has been sent, a user must delete the subscription before entering a new integration key.

    • Pending: Peoplenet has not processed the integration key.

    • Valid: The integration key entered is a valid key with Peoplenet.

    • Invalid: The integration key entered is not an active integration key.
      • Note: Review and edit the entered key to ensure it is correct. Click Resend Validation to resend the key to Peoplenet. 

  7. Define the customers using Peoplenet for time entry in the Select Customers section. 
    Note: Each customer must be activated at the "corporate" level as well as the "department" level. 
    • Some customers feature departments. Click the small plus sign to the left of a customer to display departments. Changes made on a customer level will not apply to departments unless confirmed in the pop-up dialogue. 
      • Note: The customers displayed are based on a user's branch settings. 

    • In the Clock column, select what type of time clock the customer is using. 
      • Note: The clock type set here is the default clock type for the customer's orders. 

    • In the Subscribed column, click the box if the customer is subscribed to Peoplenet.

    • In the Active column, click the box if the customer is actively using Peoplenet. 

  8. Click Save Customer Settings to save the settings.

 

 

 

Import Mapping Configuration

This action only needs to be taken at the onset of the Peoplenet integration. Edits can be made to terms at any time, however, ongoing changes do not need to be made.

 

To transfer data precisely, the payroll terms used in your system must be mapped to match Peoplenet terms. If Peoplenet uses the term "Regular" to describe "regular hours" and your system uses the term "Reg", the terms must be associated (mapped) to ensure accurate importing.

 

  1. Navigate to Start Page > Actions menu > Admin Tools

  2. Select Import Export Mapping. The System | Import Export Mapping Type window displays. 
    2.png

  3. Click the Mapping Type Data tab. 
    3.png

  4. In the GroupCode column, search for 'Peoplenet'. Any Peoplenet-related mapping imports will display in the grid. 

  5. Click the Peoplenet Mapping row. The Mapping Type transactions area shows the Peoplenet terms in the MapFromID column.
    4.png

  6. Enter your company's terms in the corresponding row of the MapToID column.
    5.png

  7. Click Save. The Peoplenet data will now match your company's data during an import.

 

 

User Authorization

Avionté users must be granted permission to use the Peoplenet import tool. 

  1. Navigate to Start Page > Actions menu > Admin Tools > Category = System

  2. Select Report.

  3. Open the Advance Query tab.

  4. Type the name of the targeted report in the Title column to search for the report by name. 
    6.png

  5. Click the row of the advanced query to which users will receive authorization.
    7.png

  6. In the Report Users section, select "User" or "Group."
    8.png


  7. Place a check mark next to the user or group that will have authorization.
    9.png

  8. Click Save.

  9. A "Save Complete" confirmation pop-up displays. Click OK. The report is now available to the selected user or group. A user may have to restart the application to view the newly available report. 

 

 

 

 

 

 

Usage

Importing

Before Peoplenet data can be used, it must be imported from Peoplenet into the Avionté application. 

  1. Navigate to Back Office > Import Export.

  2. Click New Batch.
    10.png

  3. Enter a description for the batch run.
    11.png

  4. Select the Mapping Group "Peoplenet Mapping”. The Processing Method will automatically be set to “People Net Import”.

  5. Browse for the file you have on your computer that you are going to be importing.
    • Select the file type from the drop-down menu in the lower-right. 
      12.png


  6. The parameters are Time Entry Batch Name which is a free text field, and then Accounting Period which is a dropdown and will show you your open accounting periods to choose from.

  7. Click Finish.The ImportExport Home page displays. 

  8. Click “Process Import Export Batch”. If there were any errors during the import, a grid will pop up showing all the lines from the import file, and any lines with errors will have a plus sign at the far left of the row.  Expand out the plus sign to see the error.
    • Note: Nothing will be imported until the file is 100% error free.

  • If there are any errors, resolve them in Avionte or on the import file, then try the import again. If any changes have been made to the file itself, the import batch may have to be discarded and a new batch may have to be imported. 

    • Common errors:

      • Invalid or Missing Mapping: Map this transaction type in Admin Tools > Import Export Mapping on the Mapping Type Data, then reprocess the file.


  • If the file import ran successfully, a "Successful" message will display and the import export batch will automatically be closed.

 

Newly created assignments belonging to subscribed customers will be sent to Peoplenet automatically via a nightly service.  Any updates to assignments are sent to Peoplenet automatically via a refresh service that is run in real time.

 

Once the pay period is closed on the Peoplenet site, Peoplenet will send a user(s) the pay file, which needs to be imported into Avionté through the Import/Export section. A successfully imported Peoplenet pay file will automatically create a Time Entry batch and associate it with the transactions from the file.

 

 

Peoplenet Time Clock Section

The Peoplenet Time Clock section will display an order's Peoplenet settings in Order > Detail > More Info side tab > Peoplenet Time Clock section

13.png

    • Note: This section will only appear if the customer is subscribed to Peoplenet. You can manage customer subscriptions in Admin Tools > Peoplenet Time Clocks

  • Click the Exclude Order box if this order's assignments should not be sent to Peoplenet.

  • View the clock type this order will be using with the Clock Type section.
    • Note: This field is not editable and is populated using the information in the Admin Tools section.

 

Show Peoplenet Time View

The Peoplenet Time View section displays exported assignments, imported pay files, and errors generated from Peoplenet.

  • Display the Peoplenet Time View window by navigating to Back Office > Time Entry > Home tab > Actions > Show Peoplenet Time View.
    14.png


    • Note: This option is only available if the user setting txn_main_ShowPeoplenetTimeView is activated.

 

The upper bar in the window displays a filter and a refresh button. The filter allows a user to only see pay files, error messages, and information from within the selected dates.

    • This filter will remain until altered by a user.

 

 

Exported - Assignments Tab

15.png

 

The Exported- Assignments tab shows each assignment that is or will be exported to Peoplenet.

 

Exported- Assignment columns:

Assignment The Assignment ID.
Last Name The last name of the employee.
First Name The first name of the employee.
Client The client the assignment is for.
Job Description A short job description.
Start Date The start date of the assignment.
Date Sent The date the assignment was exported.
Status Date The date the status most recently changed.
Status The most recent export status.

 

 

 

Click the plus sign to expand the file and view the messages associated with each assignment.

 

 

Message ID The Message ID.
Assignment The Assignment ID.
Last Name The last name of the employee.
First Name The first name of the employee.
Status Date The date of the most recent status change.
Status The status in regards to the exportation process.
Error Number The number of errors occurred.
Error Description The description of the error.

 

 

Imported - Pay Files Tab

16.png

Note: Most clients do not use this functionality as it is only a feature in the full integration, rather than the more commonly used "hybrid" integration. This functionality is only visible if a customer is using the full integration.

 

The Imported- Pay Files tab displays all of the pay files for the customers subscribed to Peoplenet. All orders for a single customer, with all departments included, are combined into one pay file for the week.

 

Imported- Pay Files columns (upper portion):

Message ID The ID of the message.
Date Sent The date the message was sent to Peoplenet.
Total Records The total number of records for the worked week in the pay file.
Processed The number of records processed in the pay file.
Unprocessed The number of records unprocessed in the pay file.
Status The most recent import status.
Process Click the button to process the files after review. 

 

 

Click the small plus sign next to the pay file to view the daily punches of the employees assigned to orders under a customer.

 

 

Individual Daily Punches columns:

Assignment The Assignment ID.
Last Name The last name of the employee.
First Name The first name of the employee.
Client The client the assignment is for.
Trans Date The date of the time punches.
Pay Code The pay code, indicating if the transaction is regular time, overtime, double time, etc.
Pay Unit The total pay units for the transaction.
Bill Unit The total bill units for the transaction.
Approved By The username of the user who approved the time.
Approval Date The date of time approval.
Processed A checkmark is a visual cue indicating the file has been processed. This field is not editable.

 

 

Imported- Pay Files columns (lower portion):

Message ID The ID of the message.
Last Name The last name of the employee.
First Name The first name of the employee.
Assignment The Assignment ID.
Trans Date The date the transaction occurred.
Error Date The date the error occurred.
Error Source The source of the error.
Error Message Displays any error message associated with the import.
Voided  

 

 

 

Messaging Errors Tab

17.png

 

The Messaging Errors tab contains the errors that occurred during processing.

 

Messaging Errors columns:

Message ID The Message ID of the pay file.
Assignment The Assignment ID.
Error Date The date the error occurred.
Error Origin The origin of the error.
Error Source The source of the error.
Error Message The error message.

 

 

Process a Pay File from Peoplenet 

Note: Most clients do not use this functionality as it is only a feature in the full integration, rather than the more commonly used "hybrid" integration. This functionality is only visible if a customer is using the full integration.

 

Display the Peoplenet Time View window by navigating to Back Office > Time Entry > Home > Actions > Show Peoplenet Time View.

  1. Click on the Imported - Pay Files tab.

  2. Select the desired pay file, and expand the view by clicking the plus sign next to the pay file.

  3. Review the punches to ensure they are correct.

  4. Click the Process button for the selected pay file.

  5. Ensure the accounting period in the pop-up window is correct. Click Yes to continue. 

    • If the accounting period is not correct, click No and return to the home page of Time Entry and choose the correct accounting period. Once the accounting period is correct, follow the steps 1-4 in this section, and click Yes to continue. 

  6. A pop-up dialogue will display the total number of files successfully processed. Click OK to continue. After the payfile has been processed, a batch will automatically be created in Time Entry.
    • Note: Any errors that occur during this process will populate in the lower portion of the window in the Pay File Processing Errors section.
       
  7. To review the processed pay file, navigate to Back Office > Time Entry > Actions > Show Sheet View or Show Card View.

  8. Review and verify the transactions are correct. View the daily punches for each employee in CardView.

  9. Click Verify Batch. Resolve any errors that occur.

  10. Click Close Batch to close the batch.

  11. Continue to process Payroll as normal. 

Have more questions? Submit a request

0 Comments


This space is for article feedback only. To make a request of the Avionté Support Team, please submit a ticket to https://support.avionte.com.